• last updated a few minutes ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Fix documentation

Check that all competences exist inside of the get_set_id api, so that it can be embedded in the same query, make it possible that the returned set is empty, so that the require logic makes sense

Take retrieving the set_id out of the transaction, comment de-facto dead code and add remark

Prefer dict idioms

Avoid extra transaction on single statement

Inline SQL to fetch the current item and check for existance

Go to the datamodel directly to reduce number of queries

No need to check for existance in a separate query, prefer portable idioms

Use a slightly faster idiom to check for existance

Prefer doc as a tcl literal

Prefer plain NaviServer api to quote database lists

Make test api private, formatting changes

Document public api

Document public classes

Add doc to public classes

Prefer bind variables in sql idiom

Split statements into multiple database commands:

issuing multiple sql statements in the same command is a undocumented feature, probably exploited for performance reason, but not officially supported. The dml api will check if the first statement (supposed to be the only one) is actually a DML one. As the first statement in the chain is a select, the command fails.

Fixes xolp automated tests

Add tested procs to test cases

fix typo

avoid "tuple concurrently updated" errors from PostgreSQL

These errors are produced from PostgreSQL, when multiple

"CREATE OR # REPLACE FUNCTION" SQL are executed..

see e.g.:

https://stackoverflow.com/questions/40525684/tuple-concurrently-updated-when-creating-functions-in-postgresql-pl-pgsql

Update spanish message keys

    • -0
    • +4
    ./catalog/xolp.es_ES.ISO-8859-1.xml
  1. … 2 more files in changeset.
Indroduce new indexes on xolp_activity_hierarchy_bridge and xolp_competency_set_bridge

Add 'package_id' for tests so it does not need to be guessed

Add 'package_id' for tests so it does not need to be guessed

Reuse computations

Add 'package_id' for tests so it does not need to be guessed

Rename 'random', 'randomInit' and 'randomRange' procs to something compliant to OpenACS naming convention, replace occurrences, create deprecated wrapper

Fix typo

Do not require uuid package anymore

Use ns_uuid Naviserver command instead of uuid::uuid generate from tcllib: apparently, this can interact badly with clock localized formatting, leading to the "GREGORIAN_CHANGE_DATE" issue