gustafn in OpenACS

Improve spelling

- Internationalize title of /members page for main site memberships

- Make displayed columns of member page configurable and show ordinary members less columns

Use themed template in template used in user::workspace callback

Correct square braces

Add link to package url for application groups in user-subsite "portlet"

Reflow content

Standardize spelling of "E-Mail" in German

- allow slghtly larger images

Support image sizes on png portraits (as supported by NaviServer)

Offer admin the ability to send a notification email after approvals to communities

Bump version number to make dependency on kernel changes (i18n) explicit

    • -3
    • +3
extend message keys

Complete message keys

Add as well API functions [membership_rel::get] and

[membership_rel::get_group_id] analogous to [membership_rel::get_user_id]

Add new API call membership_rel::get_user_id to avoid code duplication

Support internationalization via [group::get_member_state_pretty] and

other related messages concerning state changes.

Centralize message handling for member_state management in group::get_member_state_pretty. More can be done, i18n needs to be added as well (required to having a more generalized handling of memberships in acs-admin and acs-subsite/www/members

make parsing of sql argument names more robust

Show member state in user-subsites listing

- Make file more modular

- Improve documentation

Maintain group_id when usering filters (was previously lost)

Increase size of URL, remove default, since it does not match well with required/non-required

Add ability to include actual user in the access log (see as well updated sample OpenACS config file in the NaviServer repository)

Remove over-eager safety check

Prefer variable over proc to access the kernel id

Use ad_include_contract to simplify code

use API rather than duplicated SQL queries

Improve message key

Modernize Tcl code

reflow overlong lines

    • -14
    • +47