• last updated 32 mins ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Add missing constraint at creation

    • -0
    • +1
    ./postgresql/news-aggregator-tables-create.sql
Make guid,source_id unique for na_items

    • -0
    • +5
    ./postgresql/upgrade-0.9d-0.10d.sql
  1. … 3 more files in changeset.
na_items_item_id_seq created before na_items tables

    • -1
    • +1
    ./postgresql/news-aggregator-tables-create.sql
fix type and move na_items_item_id sequence create statement up before na_items table create statement

    • -1
    • +1
    ./postgresql/news-aggregator-packages-drop.sql
    • -1
    • +1
    ./postgresql/news-aggregator-tables-create.sql
straightened out grouping issue in display (ran into the old issue detailed here - http://openacs.org/bugtracker/openacs/bug?bug%5fnumber=428); backing out maltes upgrade script change as it doesn't break anything and will create inconsistent data model - portlet should really be updated to fix the issue; tagging for rel v0.9.9

  1. … 9 more files in changeset.
Removed deletion of package_id otherwise any upgrade is screwed

fixed display issue with group tag by separating the two cases (one source/multiple sources to display) into to includible chunks

  1. … 6 more files in changeset.
remove debugging for multiple group by; drop title column for na_sources (not used by UI plus part of acs_objects with 5.2) and made user_id optional for source::new; still need to deal with the group by issue on index page - now, the first grouping (pub date) is not applied when there is only one source (source_id being the second grouping

  1. … 3 more files in changeset.
file upgrade-0.9.7-0.9.8.sql was initially added on branch oacs-5-2.

    • -0
    • +0
    ./postgresql/upgrade/upgrade-0.9.7-0.9.8.sql
lots of little tweaks for data cleanup on uninstantiate, some more UI work, bug fixes, etc.; added daveb's sweeper proc; not tagging v0.9.8 just yet though

    • -11
    • +3
    ./postgresql/news-aggregator-packages-create.sql
    • -0
    • +1
    ./postgresql/news-aggregator-tables-create.sql
  1. … 23 more files in changeset.
thought about puting off adding back the constraints a few version until we're pretty sure anyone out there with older versions has had a chance to get through earlier upgrades but then thought better of it

thought about puting off adding back the constraints a few version until we're pretty sure anyone out there with older versions has had a chance to get through earlier upgrades but then thought better of it

duh... bad comment in upgrade script

add a few indexes

    • -1
    • +4
    ./postgresql/news-aggregator-tables-create.sql
file upgrade-0.9.6b-0.9.7.sql was initially added on branch oacs-5-2.

    • -0
    • +0
    ./postgresql/upgrade/upgrade-0.9.6b-0.9.7.sql
couple of errors/typos in the upgrade scripts

  1. … 1 more file in changeset.
file upgrade-0.9.4d-0.9.5b.sql was initially added on branch oacs-5-2.

    • -0
    • +0
    ./postgresql/upgrade/upgrade-0.9.4d-0.9.5b.sql
file upgrade-0.9d-0.9.4d.sql was initially added on branch oacs-5-2.

    • -0
    • +0
    ./postgresql/upgrade/upgrade-0.9d-0.9.4d.sql
Minor tweaks to the UI and data model to better support instance awareness and manageability. The Oracle code is WAY out of date and, not having an Oracle install, I'm not going to worry about it now. Version bumped to 0.9.5b and I removed Simon from owner list as he's no longer active in the community. Release will be tagged oacs-5-1-compat but work will need to be done to get it going on oacs-5-2.

    • -3
    • +7
    ./postgresql/news-aggregator-tables-create.sql
  1. … 24 more files in changeset.
setting the default on alter is not supported in PG7.4

    • -3
    • +7
    ./postgresql/upgrade/upgrade-0.6-0.7d.sql
The upgrade script was named incorrectly. Fixes #2710

    • -210
    • +0
    ./postgresql/upgrade/upgrade-0.5d-0.6d.sql
    • -0
    • +210
    ./postgresql/upgrade/upgrade-0.6-0.7d.sql
file upgrade-0.6-0.7d.sql was initially added on branch oacs-5-2.

    • -0
    • +0
    ./postgresql/upgrade/upgrade-0.6-0.7d.sql
Fixing upgrade

    • -0
    • +210
    ./postgresql/upgrade/upgrade-0.5d-0.6d.sql
    • -0
    • +73
    ./postgresql/upgrade/upgrade-0.7d-0.8d.sql
file upgrade-0.5d-0.6d.sql was initially added on branch oacs-5-2.

    • -0
    • +0
    ./postgresql/upgrade/upgrade-0.5d-0.6d.sql
file upgrade-0.7d-0.8d.sql was initially added on branch oacs-5-2.

    • -0
    • +0
    ./postgresql/upgrade/upgrade-0.7d-0.8d.sql
commit to OACS-5-2 merge of changes on OACS-5-1

(using tag vg-merge-dotlrn-2-1-20050922) for packages under dotlrn-all

    • -0
    • +67
    ./oracle/news-aggregator-create.sql
    • -0
    • +181
    ./oracle/news-aggregator-package-create.sql
    • -0
    • +13
    ./oracle/news-aggregator-package-drop.sql
    • -0
    • +121
    ./oracle/upgrade/upgrade-0.1d-0.2d.sql
    • -0
    • +179
    ./oracle/upgrade/upgrade-0.5d2-0.5d3.sql
  1. … 42 more files in changeset.
file upgrade-0.5d2-0.5d3.sql was added on branch oacs-5-2 on 2005-09-26 08:54:34 +0000

    • -0
    • +0
    ./oracle/upgrade/upgrade-0.5d2-0.5d3.sql
Fix bug #2341 applying patch 723 and providing update script for oracle

    • -0
    • +179
    ./oracle/upgrade/upgrade-0.5d2-0.5d3.sql
file upgrade-0.5d2-0.5d3.sql was initially added on branch oacs-5-1.

    • -0
    • +0
    ./oracle/upgrade/upgrade-0.5d2-0.5d3.sql
Fix bug #2341 applying patch 723 and providing update script for oracle

    • -2
    • +62
    ./oracle/news-aggregator-package-create.sql
    • -0
    • +3
    ./oracle/news-aggregator-package-drop.sql
  1. … 3 more files in changeset.