• last updated 14 hours ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Fix regression in db_multirow_group_last_row_p

Row is last when the next value changes

Many thanks to Miachel Aram for reporting the issue

fix typo

::util::resources::resource_info_procs: function to improve roustness of fetching of resource info procs

bumped version number to 5.10.1b10

  1. … 1 more file in changeset.
improved souce code documentation

added link to snyk advisor (bumped version to 5.10.1b9)

  1. … 3 more files in changeset.
Further simplify handling of resource_info specs

- Added convenience function "::util::resources::register_urns" to

register all URNs with CSP handling provided by a package (denoted

by its top level namespace)

- made parameter "version" in "check-installed" include optional

- bumped version number to 5.10.1b8

  1. … 2 more files in changeset.
reduced verbosity in the system log, provide hint to message

Fixed issue in cluster mode, denoted by Khy H in the OpenACS forum

A new command "ad_parameter_cache_flush_dict" was introduced to handle

the case, where a cluster node modifies a parameter value without

having it read before. This case could lead to a coherency problem for

parameter values.

Background:

This proc is necessary in cases, where a node writes a new

parameter value before it has read the old one.

Since a plain "nsv_dict unset ad_param $key $parameter_name"

raises an exception, when the pair does not exist, and we do

not want to allow in cluster requests arbitrary "catch"

commands, we allow "ad_parameter_cache_flush_dict" instead.

Probably, the best solution is to add support for

nsv_dict unset -nocomplain -- ad_param $key $parameter_nam

The existing nsv_dict was built after Tcl's "dict unset",

which does not have the "-nocomplain" option either. However,

an atomic operation would certainly be preferable over an exists/unset

pair, which is no acceptable solution.

For details, see https://openacs.org/forums/message-view?message_id=5822470

perform proper cleanup after regressin test

Prettify subsite admin page

- Made explicit that "Administration" means "Subsite Administration"

(use the term consistently)

- Changed message key of acs-subsite.administration to "Subsite Administration"

- added icons to subsite admin index page (full set only for bootstrap icons)

  1. … 8 more files in changeset.
fix over-eager renaming

spell "site-wide" consistently with a dash

  1. … 33 more files in changeset.
factored out vulerability check to make it reusable

- New proc ::util::resources::check_vulnerability

- bumped verison number to 5.10.1b7

  1. … 3 more files in changeset.
improved spelling

  1. … 3 more files in changeset.
added comment

Use ns_parseurl to validate the URL and to determine the hostname

Latest released NaviServer still requires for servers using SNI that the -hostname flag is specified with ns_http, while it seems that in latest code we can omit it

The wrapper utility already takes care of this

Ease management of external js packages to automate admin tasks

- provide explicit information about optional package paramters

- make these accessible from site-wide admin pages

- provide information, how the configuration of the version number happend

- improve design of site-wide admin pages with action items

- further streamlined handling of external js packages

  1. … 18 more files in changeset.
renamed misnomer "ad_parameter_from_file"

- removed hints on "*.ini" files

- provided a name that points to the configuration file ("ad_parameter_from_configuration_file")

- deprecated old name

- updated documentation with examples

js-libraries: improved naming of variables

Changed name "installedVersion" to "configuredVersion", since

the former might lead to the impression, that it refers only

to the locally installed version. Instead, this refers as well

to a CDN version (when available)

  1. … 18 more files in changeset.
js-libraries: removed variable "resourceUrl"

The variable "resourceUrl" was always used in a single branch but set

for all branches before. To ease maintenance and simplify

comprehension, it was removed.

  1. … 10 more files in changeset.
tdom: "dom parse -html" implies the "simple" parser

The flag "-simple" is not needed when parsing with the flag "-html". This meanse

that

dom parse -simple -html ...

is equivalent with

dom parse -html ...

  1. … 3 more files in changeset.
Always use "--" in "dom parse" when document is interpolated

This is a safety measure to make sure that the document parsed is

never confused with an option, when the document starts with a "-". In

the best case, the error message provided by "dom parse" might be

misleading. This might be a problem for user contributed documents

(passed as variables, or return values from functions).

The double dash is supported in tdom since version 0.9.0.

  1. … 14 more files in changeset.
In essence, this change renames "version_dir" to "version_segment" as

well as "versionDir" to "versionSegment" to reflect the fact, that

this variable does not denote a directory, but a part of the path

appended to path "resourceDir".

  1. … 4 more files in changeset.
various small fixes for js libraries

- fixed page contract in case a non-default version is downloaded

- provide always an argument "-version" to resource_info procs

- obtain current version number always via resource_info.installedVersion

(it refers to CDN and locally installed version)

- pass always versionDir via resource_info to ::util::resources::download

- always obtain version_dir from resource_info

  1. … 25 more files in changeset.
add "--" to separate argument list from potentially confusing (and externaly provided) content

added handling of literal object "arraycontainer"

Improved resource information for external libraries

- added vulnerability check for a particular version

- centralized URL generation for cdnjs URLS (will reduce maintenance work, when external URL changes)

- improve behavior when running without an Internet connection

  1. … 11 more files in changeset.
Fix permission::write_permission_p. Before, the check if the user was the creation_user was always made against the currently logged in user, not the party given by the caller.

Fix default https port in security::configured_driver_info