• last updated 9 hours ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Avoid calling depreacted content_item__new/17, call content_item__new/21 instead

    • -3
    • +7
    ./postgresql/acs-messaging-packages.sql
    • -0
    • +114
    ./postgresql/upgrade/upgrade-5.10.0d1-5.10.0d2.sql
  1. … 1 more file in changeset.
file upgrade-5.10.0d1-5.10.0d2.sql was initially added on branch oacs-5-10.

    • -0
    • +0
    ./postgresql/upgrade/upgrade-5.10.0d1-5.10.0d2.sql
merged changes from the oacs-5-9 branch and resolved conflicts

    • -16
    • +27
    ./oracle/acs-messaging-packages.sql
    • -0
    • +136
    ./oracle/upgrade/upgrade-5.9.1d1-5.9.1d2.sql
    • -231
    • +110
    ./postgresql/acs-messaging-packages.sql
    • -0
    • +108
    ./postgresql/upgrade/upgrade-5.9.0-5.9.1d1.sql
    • -0
    • +103
    ./postgresql/upgrade/upgrade-5.9.1d1-5.9.1d2.sql
    • -0
    • +198
    ./postgresql/upgrade/upgrade-5.9.1d2-5.9.1d3.sql
  1. … 7829 more files in changeset.
Make same changes as for acs_message__new_file/13 to acs_message__new_image/15

    • -60
    • +16
    ./postgresql/acs-messaging-packages.sql
    • -0
    • +74
    ./postgresql/upgrade/upgrade-5.9.1d2-5.9.1d3.sql
- fix call to acs_message__new_file() (use correct types)

- drop acs_message__new_file/13 by making last argument of acs_message__new_file/13 a default

    • -57
    • +19
    ./postgresql/acs-messaging-packages.sql
    • -0
    • +63
    ./postgresql/upgrade/upgrade-5.9.1d2-5.9.1d3.sql
- Don't call deprecated interfaces of content_revisions__new()

- bump version number to 5.9.1d3

    • -22
    • +25
    ./postgresql/acs-messaging-packages.sql
    • -0
    • +61
    ./postgresql/upgrade/upgrade-5.9.1d2-5.9.1d3.sql
  1. … 1 more file in changeset.
file upgrade-5.9.1d2-5.9.1d3.sql was initially added on branch oacs-5-9.

    • -0
    • +0
    ./postgresql/upgrade/upgrade-5.9.1d2-5.9.1d3.sql
file upgrade-5.9.1d1-5.9.1d2.sql was initially added on branch oacs-5-9.

    • -0
    • +0
    ./oracle/upgrade/upgrade-5.9.1d1-5.9.1d2.sql
    • -0
    • +0
    ./postgresql/upgrade/upgrade-5.9.1d1-5.9.1d2.sql
Removed RFC822 id generation from acs_message__new stored procedure:

beside being replication of what already available in proc acs_mail_lite::generate_message_id,

it was buggy, because it assumed http protocol (no https) and also broke General Comments

on installations that by chance had an empty SystemURL parameter

    • -16
    • +27
    ./oracle/acs-messaging-packages.sql
    • -0
    • +136
    ./oracle/upgrade/upgrade-5.9.1d1-5.9.1d2.sql
    • -29
    • +36
    ./postgresql/acs-messaging-packages.sql
    • -0
    • +103
    ./postgresql/upgrade/upgrade-5.9.1d1-5.9.1d2.sql
  1. … 4 more files in changeset.
- fix bug showing up with acs-messaging: some installation did not have wrapper version for acs_message__new/16. red rid of it and use default in /17 version

    • -68
    • +19
    ./postgresql/acs-messaging-packages.sql
    • -0
    • +108
    ./postgresql/upgrade/upgrade-5.9.0-5.9.1d1.sql
  1. … 1 more file in changeset.
file upgrade-5.9.0-5.9.1d1.sql was initially added on branch oacs-5-9.

    • -0
    • +0
    ./postgresql/upgrade/upgrade-5.9.0-5.9.1d1.sql
- add function args missed by earlier upgrades

- bump version numbers

    • -0
    • +18
    ./postgresql/upgrade/upgrade-5.9.0d1-5.9.0d2.sql
  1. … 9 more files in changeset.
- update postgres function to modern style plpgsql definitions, avoid backslash escaping

- add missing function_args

    • -16
    • +42
    ./postgresql/acs-messaging-create.sql
    • -293
    • +471
    ./postgresql/acs-messaging-packages.sql
    • -32
    • +40
    ./postgresql/upgrade/upgrade-4.6.2-4.6.3.sql
    • -6
    • +15
    ./postgresql/upgrade/upgrade-5.0.0b3-5.0.0b4.sql
    • -34
    • +42
    ./postgresql/upgrade/upgrade-5.8.0d1-5.8.0d2.sql
Some time ago some plpgsql functions were changed in order to be compatible with pg 8.x, create scripts were modified but upgrade scripts were missing ( at least i couldn't find them) http://fisheye.openacs.org/changelog/OpenACS?cs=MAIN%3Ajeffd%3A20090210183154 . Bumping up package versions accordingly.

    • -0
    • +98
    ./postgresql/upgrade/upgrade-5.8.0d1-5.8.0d2.sql
  1. … 7 more files in changeset.
switch foo_id_seq.netval to nextval('t_foo_id_seq') calls to placate postgresql 8.

    • -2
    • +2
    ./postgresql/acs-messaging-packages.sql
  1. … 8 more files in changeset.
Correction of name constraint

  1. … 5 more files in changeset.
Correction of name constraint

  1. … 2 more files in changeset.
Fix #2981: table_name and id_column must be null for acs_message_revision object type

    • -0
    • +1
    ./oracle/upgrade/upgrade-5.3.0d1-5.3.0d2.sql
    • -0
    • +1
    ./postgresql/upgrade/upgrade-5.3.0d1-5.3.0d2.sql
  1. … 1 more file in changeset.
Fix typo in table_name for acs_messages object type

Made tables etc lower-case to satisfy Jeff's coding standards automated

tests.

Merged acs-core oacs-5-2 (currently 5.2.3) -> HEAD.

TODO:

1. Bump acs-core package version numbers to 5.3.0d1

2. Would be nice to do a test install, wouldn't it?

    • -0
    • +655
    ./oracle/upgrade/upgrade-5.2.1d1-5.2.1d2.sql
  1. … 720 more files in changeset.
file upgrade-5.2.1d1-5.2.1d2.sql was initially added on branch oacs-5-2.

    • -0
    • +0
    ./oracle/upgrade/upgrade-5.2.1d1-5.2.1d2.sql
Support root parent_id as -4 instead of 0. Postgresql doesn't have a default for parent_id so it doesn't get an upgrade script.

    • -0
    • +655
    ./oracle/upgrade/upgrade-5.2.1d1-5.2.1d2.sql
  1. … 1 more file in changeset.
Applying patch 394: fix for upgrade script 4.6.2-4.6.3

Applied patch 394

various bug fixes for package_id, title addition to acs_objects

    • -2
    • +1
    ./postgresql/acs-messaging-packages.sql
  1. … 12 more files in changeset.
Remerge Timo's changes for tip 42,43, cf tip 53

    • -13
    • +25
    ./oracle/acs-messaging-packages.sql
    • -1
    • +12
    ./postgresql/acs-messaging-drop.sql
    • -75
    • +224
    ./postgresql/acs-messaging-packages.sql
  1. … 93 more files in changeset.
rollback of Timo's name, package_id commit; see TIP 53

    • -24
    • +12
    ./oracle/acs-messaging-packages.sql
    • -11
    • +0
    ./postgresql/acs-messaging-drop.sql
    • -223
    • +74
    ./postgresql/acs-messaging-packages.sql
  1. … 92 more files in changeset.
TIP#42,43: adding package_id and title to acs_objects table

    • -13
    • +25
    ./oracle/acs-messaging-packages.sql
    • -0
    • +8
    ./oracle/upgrade/upgrade-5.1.0d1-5.1.0d2.sql
    • -1
    • +12
    ./postgresql/acs-messaging-drop.sql
    • -75
    • +224
    ./postgresql/acs-messaging-packages.sql
    • -0
    • +8
    ./postgresql/upgrade/upgrade-5.1.0d1-5.1.0d2.sql
  1. … 92 more files in changeset.
merge of changes on oacs-5-0 branch to oacs-5-0-0b4 tag

    • -8
    • +6
    ./postgresql/acs-messaging-packages.sql
    • -0
    • +11
    ./postgresql/upgrade/upgrade-5.0.0b3-5.0.0b4.sql
  1. … 596 more files in changeset.