• last updated 1 hour ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Removed obsolete @arch-tag

    • -2
    • +1
    ./postgresql/site-templates-create.sql
  1. … 24 more files in changeset.
Fix reference to acs_object_type.table_name so that it points to real tables (fixes automated tests)

    • -0
    • +29
    ./oracle/upgrade/upgrade-2.10.0d2-2.10.0d3.sql
    • -0
    • +31
    ./postgresql/upgrade/upgrade-2.10.0d2-2.10.0d3.sql
  1. … 1 more file in changeset.
Remove leftover acs_attribute without a database table counterpart (fixes regression test)

  1. … 2 more files in changeset.
Fix duplicate 'the'

  1. … 22 more files in changeset.
Fix typos

  1. … 68 more files in changeset.
merged changes from the oacs-5-9 branch and resolved conflicts

    • -13
    • +13
    ./postgresql/class-memberships-create.sql
    • -24
    • +11
    ./postgresql/communities-package-create.sql
  1. … 7820 more files in changeset.
file upgrade-2.9.1b1-2.9.1b2.sql was initially added on branch oacs-5-9.

    • -0
    • +0
    ./oracle/upgrade/upgrade-2.9.1b1-2.9.1b2.sql
    • -0
    • +0
    ./postgresql/upgrade/upgrade-2.9.1b1-2.9.1b2.sql
file upgrade-2.9.1d3-2.9.1d4.sql was initially added on branch oacs-5-9.

    • -0
    • +0
    ./postgresql/upgrade/upgrade-2.9.1d3-2.9.1d4.sql
file upgrade-2.9.1d2-2.9.1d3.sql was initially added on branch oacs-5-9.

    • -0
    • +0
    ./postgresql/upgrade/upgrade-2.9.1d2-2.9.1d3.sql
file upgrade-2.9.0-2.9.1d1.sql was initially added on branch oacs-5-9.

    • -0
    • +0
    ./postgresql/upgrade/upgrade-2.9.0-2.9.1d1.sql
Merging back to HEAD branch oacs-5-8 (using tag vg-merge-oacs-5-8-from-20141027).

  1. … 2547 more files in changeset.
- use $$ quoting in postgres SQL

- use name parameter for SQL functions

- provide compatility with pg9

- replace deprecated "acs_sc_call" by "acs_sc::invoke"

- replace deprecated "ad_maybe_redirect_for_registration" by "auth::require_login"

- brace expressions

- favor tcl-compilable string comparisons

- don't use numeric comparison operator for non-numeric arguments

- use numeric comparison operator for truth value comparisons

- use "in" or "ni" expression instead of "lsearch"

- bump version number to indicate compatibility with 5.8.1

    • -25
    • +25
    ./postgresql/admin-profile-provider-create.sql
    • -20
    • +27
    ./postgresql/admin-profile-provider-drop.sql
    • -18
    • +31
    ./postgresql/admins-package-create.sql
    • -20
    • +34
    ./postgresql/admins-sanitize.sql
    • -140
    • +140
    ./postgresql/applet-sc-create.sql
    • -15
    • +15
    ./postgresql/class-membership-drop.sql
    • -55
    • +55
    ./postgresql/class-memberships-create.sql
    • -94
    • +174
    ./postgresql/communities-package-create.sql
    • -14
    • +28
    ./postgresql/communities-tree-create.sql
    • -105
    • +196
    ./postgresql/community-memberships-packages-create.sql
    • -12
    • +21
    ./postgresql/custom-permissions.sql
  1. … 132 more files in changeset.
PG 9.0 compatibility. Changes regarding the usage of sequences in order to avoid errors of 'missing FROM-clause message' on queries.

    • -2
    • +2
    ./postgresql/communities-package-create.sql
    • -2
    • +2
    ./postgresql/site-templates-create.sql
    • -0
    • +73
    ./postgresql/upgrade/upgrade-2.6.0d1-2.6.0d2.sql
  1. … 6 more files in changeset.
Upgrade scripts for application groups added to .lrn

    • -3
    • +4
    ./oracle/communities-package-create.sql
    • -0
    • +263
    ./oracle/upgrade/upgrade-2.5.0d2-2.5.0d3.sql
    • -11
    • +11
    ./postgresql/communities-package-create.sql
    • -0
    • +192
    ./postgresql/upgrade/upgrade-2.5.0d2-2.5.0d3.sql
First shot at merging oacs-5-2 apps used in .LRN to HEAD.

    • -1
    • +1
    ./oracle/admin-profile-provider-create.sql
    • -1
    • +1
    ./oracle/admin-profile-provider-drop.sql
  1. … 2464 more files in changeset.
file upgrade-2.2.0d3-2.2.0d4.sql was initially added on branch oacs-5-2.

    • -0
    • +0
    ./oracle/upgrade/upgrade-2.2.0d3-2.2.0d4.sql
file upgrade-2.2.0d1-2.2.0d2.sql was initially added on branch oacs-5-2.

    • -0
    • +0
    ./postgresql/upgrade/upgrade-2.2.0d1-2.2.0d2.sql
file upgrade-2.1.4a1-2.2.0a3.sql was initially added on branch oacs-5-2.

    • -0
    • +0
    ./postgresql/upgrade/upgrade-2.1.4a1-2.2.0a3.sql
file upgrade-2.2.0d2-2.2.0d3.sql was initially added on branch oacs-5-2.

    • -0
    • +0
    ./oracle/upgrade/upgrade-2.2.0d2-2.2.0d3.sql
file site-templates-create.sql was initially added on branch oacs-5-2.

    • -0
    • +0
    ./oracle/site-templates-create.sql
file upgrade-2.2.0d1-2.2.0d2.sql was initially added on branch oacs-5-2.

    • -0
    • +0
    ./oracle/upgrade/upgrade-2.2.0d1-2.2.0d2.sql
file site-templates-drop.sql was initially added on branch oacs-5-2.

    • -0
    • +0
    ./oracle/site-templates-drop.sql
file site-templates-create.sql was initially added on branch oacs-5-2.

    • -0
    • +0
    ./postgresql/site-templates-create.sql
file upgrade-2.1.3-2.2.0a1.sql was initially added on branch oacs-5-2.

    • -0
    • +0
    ./postgresql/upgrade/upgrade-2.1.3-2.2.0a1.sql
file site-templates-drop.sql was initially added on branch oacs-5-2.

    • -0
    • +0
    ./postgresql/site-templates-drop.sql
file upgrade-2.1.3-2.2.0d1.sql was initially added on branch oacs-5-2.

    • -0
    • +0
    ./postgresql/upgrade/upgrade-2.1.3-2.2.0d1.sql
file upgrade-2.1-2.2.0d1.sql was initially added on branch oacs-5-2.

    • -0
    • +0
    ./postgresql/upgrade/upgrade-2.1-2.2.0d1.sql
remove upgrade scripts that were created in darkages for which there is no relevant deployed instance

    • -1
    • +0
    ./oracle/upgrade/upgrade-july-25-2002.sql
    • -2
    • +0
    ./oracle/upgrade/upgrade-jun-07-2002.sql
    • -29
    • +0
    ./oracle/upgrade/upgrade-jun-12-2002.sql
commit to HEAD of merge of changes on oacs-5-1 branch between tags jcd-merge-5-1-20040724 and jcd-merge-5-1-20050111

  1. … 2275 more files in changeset.
file upgrade-2.1.0a2-2.1.0b1.sql was initially added on branch oacs-5-1.

    • -0
    • +0
    ./oracle/upgrade/upgrade-2.1.0a2-2.1.0b1.sql