• last updated 4 hours ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Avoid calling depreacted content_item__new/17, call content_item__new/21 instead

file upgrade-5.10.0d1-5.10.0d2.sql was initially added on branch oacs-5-10.

    • -0
    • +0
    ./sql/postgresql/upgrade/upgrade-5.10.0d1-5.10.0d2.sql
Formatting changes

    • -5
    • +5
    ./tcl/acs-messaging-procs-postgresql.xql
Reduce divergency between oracle and postgres codebase

    • -10
    • +0
    ./tcl/acs-messaging-procs-oracle.xql
    • -6
    • +0
    ./tcl/acs-messaging-procs-postgresql.xql
mark functions called only internally as private

  1. … 15 more files in changeset.
Fix brackets in expression

improve spelling

  1. … 12 more files in changeset.
make tested api calls explicit

fix typo

regenerated documentation

Fix typos

  1. … 30 more files in changeset.
Fix typos

  1. … 33 more files in changeset.
fix more typos

  1. … 5 more files in changeset.
Reduce divergency between oracle and postgres codebase, remove duplicated query definition from oracle xql

    • -60
    • +0
    ./tcl/acs-messaging-procs-oracle.xql
    • -39
    • +0
    ./tcl/acs-messaging-procs-postgresql.xql
merged changes from the oacs-5-9 branch and resolved conflicts

    • -16
    • +27
    ./sql/oracle/acs-messaging-packages.sql
    • -0
    • +136
    ./sql/oracle/upgrade/upgrade-5.9.1d1-5.9.1d2.sql
    • -0
    • +108
    ./sql/postgresql/upgrade/upgrade-5.9.0-5.9.1d1.sql
  1. … 7820 more files in changeset.
regenerated ducumentation

  1. … 249 more files in changeset.
- do not depend on beta or development versions

- make sure that released versions are not beta or development

- align version numbers (e.g. use also 5.9.1 for xotcl-core)

- bump version numbers to 5.9.1

  1. … 83 more files in changeset.
bump version numbers to 5.9.1b9 respectively to 2.9.1b9 to prepare for release

  1. … 91 more files in changeset.
Fix spelling errors

  1. … 10 more files in changeset.
- bump version number of OpenACS to 5.9.1b3 and DotLRN to 2.9.1b3

  1. … 79 more files in changeset.
Bump version numbers for OpenACS 5.9.1b1

  1. … 81 more files in changeset.
Make same changes as for acs_message__new_file/13 to acs_message__new_image/15

- fix call to acs_message__new_file() (use correct types)

- drop acs_message__new_file/13 by making last argument of acs_message__new_file/13 a default

- Don't call deprecated interfaces of content_revisions__new()

- bump version number to 5.9.1d3

file upgrade-5.9.1d2-5.9.1d3.sql was initially added on branch oacs-5-9.

    • -0
    • +0
    ./sql/postgresql/upgrade/upgrade-5.9.1d2-5.9.1d3.sql
file upgrade-5.9.1d1-5.9.1d2.sql was initially added on branch oacs-5-9.

    • -0
    • +0
    ./sql/oracle/upgrade/upgrade-5.9.1d1-5.9.1d2.sql
    • -0
    • +0
    ./sql/postgresql/upgrade/upgrade-5.9.1d1-5.9.1d2.sql
Removed RFC822 id generation from acs_message__new stored procedure:

beside being replication of what already available in proc acs_mail_lite::generate_message_id,

it was buggy, because it assumed http protocol (no https) and also broke General Comments

on installations that by chance had an empty SystemURL parameter

    • -16
    • +27
    ./sql/oracle/acs-messaging-packages.sql
    • -0
    • +136
    ./sql/oracle/upgrade/upgrade-5.9.1d1-5.9.1d2.sql
  1. … 3 more files in changeset.
- fix bug showing up with acs-messaging: some installation did not have wrapper version for acs_message__new/16. red rid of it and use default in /17 version

    • -0
    • +108
    ./sql/postgresql/upgrade/upgrade-5.9.0-5.9.1d1.sql
file upgrade-5.9.0-5.9.1d1.sql was initially added on branch oacs-5-9.

    • -0
    • +0
    ./sql/postgresql/upgrade/upgrade-5.9.0-5.9.1d1.sql
- use entities for single quotes in HTML text

  1. … 73 more files in changeset.