• last updated 12 hours ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
improve spelling: move closer to the linux documentation recommendations

  1. … 27 more files in changeset.
Fix for plausible file checking in cr_delete_orphans

The code checks for files, which are not conforming to the naming conventions,

and intends to skip these. ... but a "continue" was missing.

Many thanks to Franz Penz

Whitespace cleanup

Reduce divergency between oracle and postgres codebase, bring portable sql inline

Rename ReturnHeaders proc to comply with OpenACS naming convention, create deprecated wrapper, replace occurrences

  1. … 10 more files in changeset.
Move CR search callbacks to new namespace in compliance with OpenACS naming convention, create deprecated wrappers, update service contract tables

  1. … 3 more files in changeset.
Prefer bind variables, use portable idioms

Add ad_library and a bit of doc

Whitespace cleanup

Add cast (many thanks to Franz Penz for the change)

improve spelling

New utility to return all descendants of a certain cr_item or folder

Whitespace cleanup

Add a simple test case for 'content::revision::get_title'

    • -3
    • +10
    ./test/content-revision-test-procs.tcl
Add 'content::revision::get_title', a simple proc to get the title of a particular 'content_revision'

Adjust doc and defaults of 'content::item::get_title' to the actual implementation of 'content_item__get_title'

Remove self-reference in proc doc

replace hardcoded /tmp by API function [ad_tmpdir]

  1. … 10 more files in changeset.
improve spelling

  1. … 16 more files in changeset.
Whitespace cleanup

Prefer db quoting

Replace ad_decode idiom, prefer db quoting

Replace ad_decode idiom with plain sql

whitespace changes

Whitespace changes

Add missing 'title' parameter to 'content::item::upload_file', which is checked in the proc and probably not materialized out of thin air.

Use '::content::item::get_content_type' instead of the deprecated '::content::item::content_type'

Use '::content::item::get_content_type' instead of the deprecated '::content::item::content_type'

Trailing whitespace cleanup

Deprecate '::content::item::content_type', which is exactly the same proc as 'content::item::get_content_type'. Weird.