• last updated 20 hours ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
make using page-filter "object_id" backwards compatible by allowing it to be used also during update scripts

  1. … 1 more file in changeset.
Prefer portable limit idiom, streamline query, "bad postgres" does not need this...

whitespace changes (remove tabs)

    • -21
    • +21
    ./version-dependencies-oracle.xql
    • -23
    • +23
    ./version-dependencies-postgresql.xql
  1. … 3 more files in changeset.
Remove obsolete files, initially deleted in oacs-5-8 branch, 8 years ago, which somehow managed to survive

Remove obsolete file, initially deleted in oacs-5-8 branch, 8 years ago, which somehow managed to survive

Prefer 'namespace which' over 'info commands', as it is faster (on local tests, around 2x) and returns a single value. Many thanks to Nathan Coulter.

  1. … 58 more files in changeset.
use bind variables instead of tcl variable substition in xql fullqueries

  1. … 15 more files in changeset.
Improve sql portability

  1. … 4 more files in changeset.
improve spelling

  1. … 4 more files in changeset.
mprove spelling: move closer to the linux documentation recommendations, standardize variable names

  1. … 17 more files in changeset.
improve acs-admin//apm/packages-install

- use usual user interaction for select/unselect all

- add proper handling of no upgrades

- improve HTML markup

- improve code orthogonality

  1. … 2 more files in changeset.
when installation runs into an error, show the error message preformatted

  1. … 1 more file in changeset.
whitespace changes

  1. … 1 more file in changeset.
Prefer api to retrieve csp nonce, as it performs useful existance checks

  1. … 3 more files in changeset.
prefer all caps spelling for SQL

  1. … 2 more files in changeset.
Whitespace changes

Fix typo

improve spelling

  1. … 31 more files in changeset.
Whitespace changes

Do not assume a package is installed only if it has an entry in the 'apm_package_types' table. This fixes the issue of package upgrade prompting, in not installed packages, that still have an entry in 'apm_package_types'

whitespace changes

  1. … 1 more file in changeset.
Whitespace cleanup

Replace ad_decode idioms

Whitespace cleanup

Normalize indentation

Replace ad_decode idioms

Use cached api, bring sql inline, leverage db quoting

Replace ad_decode idioms

Replace ad_decode idioms

simplify and fix subst operation