Index: TODO =================================================================== diff -u -r2a3ac3f00afd5c5cfdfb1a9fff667cdec5b861be -r0f881e4bc45e927c8d84c1b1b468ef7537cb9b03 --- TODO (.../TODO) (revision 2a3ac3f00afd5c5cfdfb1a9fff667cdec5b861be) +++ TODO (.../TODO) (revision 0f881e4bc45e927c8d84c1b1b468ef7537cb9b03) @@ -5462,18 +5462,53 @@ - make all __* system methods in nx redefine-protected - let "nsf::configure objectsystem" return handles and protections as well +nx.tcl: pluralism reform part 3 +- introduced simple plural form "mixins" and "filters" for introspection +- moved differentiated interface into slot methods. + the slot methods "get" stay symmetrically to "set", + but additional methods "classes" or "methods" are used + like "guard" to obtain partial results of the + mixin and filter specs +- changed info methods + /cls/ info mixin classes -> /cls/ info mixins + /cls/ info filter methods -> /cls/ info filters + /obj/ info object mixin classes -> /obj/ info object mixins + /obj/ info object filter methods -> /obj/ info object filters +- dropped + /cls/ info mixin guard + /cls/ info filter guard + /obj/ info object mixin guard + /obj/ info object filter guard +- added + /cls/ mixin classes + /cls/ filter methods + /obj/ object filter methods + /obj/ object mixin classes + ======================================================================== TODO: +- EnsembleObject->unknown is still not correct + "C info object mixin classes" complains about "object" + and not about "mixin". + The message for "C info mixin classes" is fine + - finish pluaral reform - update migration guide and tutorial - maybe introdouce "allowabbrev" flag - set nodashalnum for int types - should we change "/obj/ info lookup syntax /methodName/" to return obj and method as well? (similar to "info method syntax /methodName/") + - we could drop methods::object::info::objectparameter +- do we need: ::nsf::methods::object::info::is ? objectInfoMethod is NsfObjInfoIsMethod +- we should rename ::nsf::methods::class::info::filtermethods to ::nsf::methods::class::info::filters +- we should rename ::nsf::methods::class::info::mixinclasses to ::nsf::methods::class::info::mixins +- can we drop ::nsf::methods::class::info::filterguards ? +- can we drop ::nsf::methods::class::info::mixinguards ? + - remove // comments - what should happen with: "/class/ info mixin classes -heritage"