• last updated 4 hours ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Replace legacy syntax (these are one-time operations)

Removed obsolete @arch-tag

  1. … 26 more files in changeset.
Fix typos

    • -1
    • +1
    ./oracle/upgrade/upgrade-4.1.0b-4.6.sql
    • -1
    • +1
    ./oracle/upgrade/upgrade-4.6-5.0d1.sql
    • -2
    • +2
    ./oracle/upgrade/upgrade-5.0d1-5.0d2.sql
  1. … 4 more files in changeset.
Fix typos

    • -1
    • +1
    ./oracle/upgrade/upgrade-4.1.0b-4.6.sql
    • -1
    • +1
    ./oracle/upgrade/upgrade-4.6-5.0d1.sql
    • -2
    • +2
    ./oracle/upgrade/upgrade-5.0d1-5.0d2.sql
  1. … 29 more files in changeset.
Fix more typos

  1. … 84 more files in changeset.
fix typos

  1. … 7 more files in changeset.
merged changes from the oacs-5-9 branch and resolved conflicts

    • -96
    • +55
    ./postgresql/news-package-create.sql
    • -0
    • +127
    ./postgresql/upgrade/upgrade-5.9.0d1-5.9.0d2.sql
    • -0
    • +11
    ./postgresql/upgrade/upgrade-5.9.0d2-5.9.0d3.sql
    • -0
    • +74
    ./postgresql/upgrade/upgrade-5.9.1b1-5.9.1b2.sql
  1. … 7830 more files in changeset.
Remove leftover from old installations (perform cleanup which was missing since Feb 2005)

Don't call deprecated version of content_revision__new

    • -0
    • +69
    ./postgresql/upgrade/upgrade-5.9.1b1-5.9.1b2.sql
  1. … 1 more file in changeset.
file upgrade-5.9.1b1-5.9.1b2.sql was initially added on branch oacs-5-9.

    • -0
    • +0
    ./postgresql/upgrade/upgrade-5.9.1b1-5.9.1b2.sql
- clean dirty editor buffer

- Cleanup cr_revisions belonging to the news package, for which there

are no news_id in cr_news. These entries were created since ever in

the news package. The bug adding spurious revisions was fixed with

the OpenACS 5.9.0 release, this upgrade scripts removes leftovers

of the earlier bug.

    • -0
    • +11
    ./postgresql/upgrade/upgrade-5.9.0d2-5.9.0d3.sql
  1. … 1 more file in changeset.
file upgrade-5.9.0-5.9.1d1.sql was initially added on branch oacs-5-9.

    • -0
    • +0
    ./postgresql/upgrade/upgrade-5.9.0-5.9.1d1.sql
file upgrade-5.9.0d2-5.9.0d3.sql was initially added on branch oacs-5-9.

    • -0
    • +0
    ./postgresql/upgrade/upgrade-5.9.0d2-5.9.0d3.sql
- fix bug: don't create two revisions for every news entry

- remove redundant operations from news__new()

- use default instead of two functions in news__archive()

- fix bug: don't overwrite title with lead text in search contract

- update comments

- bump version number to 5.9.0d2

    • -94
    • +52
    ./postgresql/news-package-create.sql
    • -0
    • +127
    ./postgresql/upgrade/upgrade-5.9.0d1-5.9.0d2.sql
  1. … 3 more files in changeset.
file upgrade-5.9.0d1-5.9.0d2.sql was initially added on branch oacs-5-9.

    • -0
    • +0
    ./postgresql/upgrade/upgrade-5.9.0d1-5.9.0d2.sql
Merging back to HEAD branch oacs-5-8 (using tag vg-merge-oacs-5-8-from-20141027).

    • -170
    • +258
    ./postgresql/news-package-create.sql
    • -14
    • +23
    ./postgresql/upgrade/upgrade-4.6-5.0d1.sql
    • -69
    • +86
    ./postgresql/upgrade/upgrade-5.2.0d1-5.2.0d2.sql
    • -51
    • +66
    ./postgresql/upgrade/upgrade-5.2.0d2-5.2.0d3.sql
    • -9
    • +19
    ./postgresql/upgrade/upgrade-5.2.0d5-5.2.0d6.sql
    • -42
    • +51
    ./postgresql/upgrade/upgrade-5.6.0d1-5.6.0d2.sql
  1. … 2539 more files in changeset.
- use $$ quoting in postgres SQL

- use named parameters for SQL functions

- fix/complete define_function_args

    • -170
    • +258
    ./postgresql/news-package-create.sql
    • -14
    • +23
    ./postgresql/upgrade/upgrade-4.6-5.0d1.sql
    • -69
    • +86
    ./postgresql/upgrade/upgrade-5.2.0d1-5.2.0d2.sql
    • -51
    • +66
    ./postgresql/upgrade/upgrade-5.2.0d2-5.2.0d3.sql
    • -9
    • +19
    ./postgresql/upgrade/upgrade-5.2.0d5-5.2.0d6.sql
    • -43
    • +52
    ./postgresql/upgrade/upgrade-5.6.0d1-5.6.0d2.sql
PG 9.0 compatibility. Avoiding fetching next value of sequences using a view.

    • -0
    • +135
    ./postgresql/upgrade/upgrade-5.6.0d1-5.6.0d2.sql
  1. … 4 more files in changeset.
Forgot to add my upgrade scripts ...

    • -0
    • +205
    ./oracle/upgrade/upgrade-5.5.1d1-5.6.0d1.sql
    • -0
    • +207
    ./postgresql/upgrade/upgrade-5.5.1d1-5.6.0d1.sql
Changed to use richtext and a bit of other clean-up. Tested news item create,

edit, upload from file, notifications, rss, view, admin view, etc for PG. Testing

for Oracle is next and if bugs are found, there will be a commit soon.

  1. … 21 more files in changeset.
First shot at merging oacs-5-2 apps used in .LRN to HEAD.

    • -32
    • +15
    ./oracle/upgrade/upgrade-5.0d1-5.0d2.sql
    • -9
    • +18
    ./postgresql/news-package-create.sql
    • -0
    • +76
    ./postgresql/upgrade/upgrade-5.2.0d5-5.2.0d6.sql
  1. … 2471 more files in changeset.
Fix for news__clone plsql, added lead var for news__new

    • -0
    • +76
    ./postgresql/upgrade/upgrade-5.2.0d5-5.2.0d6.sql
  1. … 1 more file in changeset.
file upgrade-5.2.0d5-5.2.0d6.sql was initially added on branch oacs-5-2.

    • -0
    • +0
    ./postgresql/upgrade/upgrade-5.2.0d5-5.2.0d6.sql
lead column created by create_attribute, no need to modify column manually

cr_news.lead column allready exists so we just change its size to varchar2 4000

Fix another missing comma!

Add missing comma

commit to OACS-5-2 merge of changes on OACS-5-1

(using tag vg-merge-dotlrn-2-1-20050922) for packages under dotlrn-all

    • -32
    • +15
    ./oracle/upgrade/upgrade-5.0d1-5.0d2.sql
  1. … 9 more files in changeset.
Additional fixes to news__clone - incorrect call to news__new and sql fixes

    • -8
    • +15
    ./postgresql/news-package-create.sql