• last updated 18 hours ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Document current preferred idiom to quote database lists, without official deprecation, for the time being

improve spelling: move closer to the linux documentation recommendations

  1. … 28 more files in changeset.
remove unused nsv variables

white-space changes

  1. … 2 more files in changeset.
internationalize confirm message

  1. … 3 more files in changeset.
template::set_css_propert: generalize function

template::hide: new API function to hide certain CSS classes via javascript

improve readability

support registration of csp rules for URNs

  1. … 1 more file in changeset.
improve wording and fix typos

  1. … 1 more file in changeset.
check, if container resource is really loaded

fix typo in variable name

Prefer api to retrieve csp nonce, as it performs useful existance checks

  1. … 2 more files in changeset.
Prefer api to retrieve csp nonce, as it performs useful existance checks

  1. … 5 more files in changeset.
Avoid sending potentially unquoted text via hidden form field

address issue #3433: add option "noquote" for the "inform" widget type

The flag is currently ignored for all other widget types

  1. … 1 more file in changeset.
use same spelling for "i.e." as everywhere else

Fix flag in proc definition

Rename template_tag proc to comply with OpenACS naming convention, create deprecated wrapper, massage variable juggling (use an absolutely namespaced variable instead of a namespace-sensitive one)

Whitespace cleanup

Rename string_truncate and string_truncate_middle to comply with OpenACS naming convention, create deprecated wrappers, replace occurrences

As string_truncate_middle was defined in xotcl-request-monitor, bring it to acs-tcl instead

  1. … 11 more files in changeset.
Bring stack_dump in the templating:: namespace to comply with OpenACS naming convention, create deprecated wrapper

Deprecate "multirow" proc as it does not comply with OpenACS naming convention

Deprecate "form" proc, as it doesn't comply with naming convention

fix warning message (many thanks to Frank Bergmann for pointing this out)

Fix regression on template list

Deprecate 'element' proc, defined without a namespace

improve spelling

Deprecate exists_and_not_null proc as it does not comply with openacs naming convention and can be replaced with plain tcl idioms

  1. … 3 more files in changeset.
Deprecate exists_and_equals and replace its occurrences

  1. … 1 more file in changeset.