• last updated 9 hours ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Cache the portrait in the right cache (Thanks to Felix Mödritscher)

Translation of file descriptor must be binary as well when flushing in-memory payload to the spool file, or we would corrupt this content

util::http performance improvements:

- cache util::http::available as namespace variable, as in the worst case it would go to the db

- replace array idioms with dict idioms

Trim whitespace

fix backslashes

overwork test cases: moderinze tests, make tested api functions explicit

Trim whitespace

Repair form validation of URL

New test to check whether configured news feeds look ok

Fix typo or this file would not load

fix typo

Trim whitespace

Fix typo

Replace array idioms with dict idioms

whitespace changes

since test case ids are only significant per package_key, record such pairs in procdoc data structure

don't raise error on wrong inputs

Display warnings in the test results page

improve testcases by removing useless expr commands

    • -10
    • +10
    /openacs-4/packages/views/tcl/test/views-procs.tcl
update tutorial: don't recommend to use "expr" for aa_true or aa_false

procdoc change: Preserve pre-existing values, e.g. from testcases, which might be loaded in a different order (testcase might be loaded before proc)

.CVS: ----------------------------------------------------------------------

improve testcases by removing useless expr commands

  1. … 3 more files in changeset.
make tested procs explicit

improve testcases by removing useless expr commands

make feedback from testruns nicer (remove redundant messages)

Declass constraint names breaking the very strict OpenACS naming convention from errors to warnings

Rationale: it is sometimes impossible to have constraint names that are both < 30 chars and consistent with the naming scheme 'table_name'_'column_name'_'constraint_type' for all those defined on a particular table (see e.g. acs_named_objects).

Breaking this convention might be suboptimal, but is not harmful in itself.

flush per-request cache (fixes regression test properly)

simplify code

improve testcase viewing page:

- use syntax highlighting to testcase body

- fix label for body:

* just use numbering when appropriate

* start numbering of bodies with 1

improve test cases: align comment with operations, remove useless "expr" commands